Home Forums eaDocX queries EA14 – Project Glossary not recognized by EADOCX

Home Forums eaDocX queries EA14 – Project Glossary not recognized by EADOCX

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
  • #9350

    Hi Team,

    I have a Project Glossary set up in the EA14
    I see entries in the list “Publish”>>”Glossary”.

    **Note: The EAXL option “Open Project Items”>>”Terms” was used to load the glossary items into the project repository. All items were loaded successfully – No problems faced !!

    Later i created a document with a Glossary section in it. (Please see attached)
    Used the default – “Insert” >> “Project Glossary” option in the EADOCX menu.

    Although the section was included in the document, when i try to generate the section it gives me the following error..

    No element of type: Project Glossary in this repository.

    Help !!!! :S

    eadocX Support

    Does the document have any content? The glossary will only contain words in the document which are present in the glossary, so an empty document will mean an empty glossary.
    Also, which eaDocX version are you using?



    I tried with and without content on the document.
    In both cases – i get the same error message

    The application versions are as follows

    eadocX Support

    I just re-ran the regression test for this feature, using EA15 and eaDocX 4.1.19, and it checks-out ok.
    My steps were:
    – check what words are in the EA glossary
    – create a package, with some of those words in the description (nice simple test)
    – Create an eaDocX Quick Document for that package
    – use eaDocX / Insert / Project glossary to add a glossary section
    – re-generate the document.
    Can you follow these steps, and see what happens please?


    Yep, This test worked for me as well.

    I think i might have the issue,

    Since the document i was updating was quite large, i was only regenerating targeted sections of the document instead of the whole document.

    Since I tried to Re-generate the Glossary Section ONLY, it did not pick up the references.
    However, when i tried re-generating the Full Document – the glossary came up.

    Sincere apologies for the trouble – guess i tried to cut a corner and failed .. :silly:

Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.

Compare licence prices

Choose the licence that’s right for you and your team


Download a free trial

Download eaTeamWorks today for several free for life features, plus no obligation, 30-day trials of all the products: eaDocX, ea Revision Manager, eaSheets, Model Expert and PortfolioManager. Discover for yourself why we sell the world’s best-selling Enterprise Architect extension.