Products

Home Forums eaDocX queries eaDocX fails on sample project

Home Forums eaDocX queries eaDocX fails on sample project

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #6284
    Patrick Julian
    Participant

    Hey there,

    this doesn’t quite look like a kickstart.
    Win 7 Prof SP1, EA 9.1, MS Word 2007

    First I get this after clicking the “Quick Document” command:

    And after confirming the msg box, this AccessViolation follows:

    I can reproduce that error.

    Interestingly, eaDocX reports a success msg even after the failure has been detected.

    #6285
    eadocX Support
    Participant

    Which model are you using to create this error? Is it one of our example models? If not, please can you send the model and I will try to reproduce the error.
    Thanks.

    #6286
    Patrick Julian
    Participant

    Here you go:

    https://www.dropbox.com/s/3xcjcxonhdlj896/eaDocX.eap

    • This reply was modified 11 years, 7 months ago by Patrick Julian. Reason: adding attachment didnt work, replaced with dropbox link
    #6289
    eadocX Support
    Participant

    Thanks for this – I just successfully generated a document from this model, so there must be something interesting happening with your environment.
    I think I can see from the error message above that there is a problem when eaDocX is talking to Word: which Word version do you have, and can you also send a screen-shot of the message which is in the image above: I can’t quite read the error details.
    Thanks

    #6290
    Patrick Julian
    Participant

    It is Word 2007.
    Here is a closeup:

    It says: It has been tried to read or write in protected memory. In many cases this is a hint that other memory is damaged. at Microsoft……etc

    EDIT:

    Wow. Now it even crashed EA when I tried to generate a report from a package that contained nothing more than a diagram with a note inside. Crash signature was:

    [code]Problemsignatur:
    Problemereignisname: BEX
    Anwendungsname: EA.exe
    Anwendungsversion: 9.1.0.909
    Anwendungszeitstempel: 4e5d76b6
    Fehlermodulname: mscorwks.dll
    Fehlermodulversion: 2.0.50727.5466
    Fehlermodulzeitstempel: 503f0115
    Ausnahmeoffset: 00281ad6
    Ausnahmecode: c0000409
    Ausnahmedaten: 00000000
    Betriebsystemversion: 6.1.7601.2.1.0.256.48
    Gebietsschema-ID: 1031
    Zusatzinformation 1: 5bef
    Zusatzinformation 2: 5beff8ab869867380dff161b91b6e136
    Zusatzinformation 3: 345a
    Zusatzinformation 4: 345afd4710f9bbbad21467fc58377fc6

    Lesen Sie unsere Datenschutzbestimmungen online:
    http://go.microsoft.com/fwlink/?linkid=104288&clcid=0x0407

    Wenn die Onlinedatenschutzbestimmungen nicht verfügbar sind, lesen Sie unsere Datenschutzbestimmungen offline:
    C:Windowssystem32de-DEerofflps.txt
    [/code]

    • This reply was modified 11 years, 7 months ago by Patrick Julian. Reason: +crash report
    #6293
    eadocX Support
    Participant

    Did you try the installation verification test ? This just uses the low- and high-level EA and eaDocX interfaces.
    From the EA main menu, select Extensions | eaDocX | Help | Check Installation. Then let me know what happens.
    Sounds like something in your Word installation is new to eaDocX.
    Thanks

    #6294
    Patrick Julian
    Participant

    Hm. In the meantime I have installed the Office 2010 trial.

    Now it only says “Failed to insert new section. Please re-start EA and eaDocX and re-load the document. If problem persists, please contact eaDocX support.”

    Additionally, in Office 2010, there is a GUI error:

    The only modification that I made to Word 2007 was to activate the display of the developer toolbar in the UI (can be done under under Word Options). I deactivated that and it had no effect so I think we can rule that out.

    Quite interestingly, after I uninstalled the Office 2010 trial and went back to Office 2007, the Installation Validation now says “High Level interface is ok”. Also the generator runs without the fatal exception.
    However, the document rendered only contains the very first page which reads “Quick Document
    Produced using eaDocX ‘Quick Document’.”
    The other sections are only visible as an entry in the preview on the left side.

    #6295
    Patrick Julian
    Participant

    I uninstalled the Office 2010 trial again.
    Back with Office 2007, I could reproduce the AccessViolationException with the very same message when generating a quick Document from another package.

    Trace output from eaDocX is the following:

    [code]eaDocX Trace Information
    ==========================

    26.11.2012 13:41:16 – Opening QuickDocument
    26.11.2012 13:41:20 – Bookmark: Info was defined in the profile, but isn’t in the document any more. It will be deleted from the profile.
    26.11.2012 13:41:21 – Inserting document Info section
    26.11.2012 13:41:21 – Generating Quick Document
    26.11.2012 13:41:21 – Generator started: eaDocX Version 3.2.5.2
    26.11.2012 13:41:21 – Generator setting: Full
    26.11.2012 13:41:21 – Deleting existing bookmarks from document
    26.11.2012 13:41:21 – Starting generating section Section1
    26.11.2012 13:41:21 – Generating Section: Section1
    26.11.2012 13:41:21 – Gen>>CommonInlinePackage, Katalogbestellung
    26.11.2012 13:41:21 – Gen>>Collection starting
    26.11.2012 13:41:21 – Gen>>GenericTable of: UseCase
    26.11.2012 13:41:22 – Gen>>Collection starting
    26.11.2012 13:41:22 – Gen>>GenericTable of: Actor
    26.11.2012 13:41:22 – Gen>>CommonInlinePackage, Rqmts
    26.11.2012 13:41:22 – Gen>>CommonInlineRequirement, Der Webshop muss dem Besucher die Möglichkeit bieten, durch ein Formular im Webshop einen Print-Katalog zu bestellen.
    26.11.2012 13:41:22 – Gen>>CommonInlinePackage, Tests
    26.11.2012 13:41:22 – Gen>>Collection starting
    26.11.2012 13:41:22 – Gen>>GenericTable of: UseCase stereotype: testset
    26.11.2012 13:41:22 – Gen>>Collection starting
    26.11.2012 13:41:22 – Gen>>GenericTable of: UseCase stereotype: testsuite
    26.11.2012 13:41:22 – Added Package: Katalogbestellung
    26.11.2012 13:41:22 – Section generated OK: Section1
    26.11.2012 13:41:22 – Generating cross references
    26.11.2012 13:41:22 – Finding forward refs
    26.11.2012 13:41:22 – Crossrefs>>UnloadProject erro inserting refs
    26.11.2012 13:41:29 – Generate successful
    26.11.2012 13:41:29 – Quick Document generated OK
    [/code]

    Again, eaDocX installation verification shows nothing unusual.

    The document is rendered but only in parts, with cryptic output like
    [code]¶BM,{F470B722-19A9-4dc0-9F97-CF2D8FBF8D60},INLINE§”[/code]
    still left in the middle of the text and tables.

    #6297
    eadocX Support
    Participant

    Is it possible for you to send a small .XMI and document to support@eadocx.com, and I will try to reproduce the error .
    Thanks

    #6298
    eadocX Support
    Participant

    ..Also the User Interface error is quite deliberate: if the a user closes Word from within Word (as opposed to closing it from eaDocX, which is fine) then this causes EA to fail!
    This is a ‘feature’ of the Word API, so we thought it was safer to blank-out the Word ‘close’ button.

Viewing 10 posts - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.

Compare licence prices

Choose the licence that’s right for you and your team

Prices

Download a free trial

Download eaTeamWorks today for several free for life features, plus no obligation, 30-day trials of all the products: eaDocX, ea Revision Manager, eaSheets, Model Expert and PortfolioManager. Discover for yourself why we sell the world’s best-selling Enterprise Architect extension.

Download