Home Forums eaDocX queries MS Office versions

Home Forums eaDocX queries MS Office versions

Viewing 15 posts - 1 through 15 (of 18 total)
  • Author
  • #6075
    Matthew Bickers

    When I open a new document (Extension –> EaDocX –> New Word Document), I receive the following error message.

    System.NullReferenceException: Object reference not set to an instance of an object.
    at eaDocXAddIn.eaDocXTabs.openTab(Repository repository, String fileName)

    Also, the quick Document link from the Package Browser does not generate a diagram at all, just a blank page with text “… no current diagram…”.

    Any ideas what this could be?

    I am running Microsoft Word Starter, not the full Microsoft Office suite. Could this cause issues?

    I am running EaDocX with a 30 day trial license against a 9.1.910 version of EA.


    eadocX Support

    Oh yes.
    eaDocX only supports full MS Office, not starter.
    The problem with these other versions is that they don’t have the full MS Word function. In normal use, I think they then download the bits they don’t have, as you try to use a new function.
    But, when these ‘missing’ bits are used via the Word APIs (as eaDocX does) then Word doesn’t download them, and there’s nothing we can do to fix this.

    Forum User


    I have the same problem with eaDocX 30-days trial,
    EA 10.0.1004
    and MS Word 2010 Professional (not Starter).

    Could you please help me?

    • This reply was modified 11 years, 2 months ago by Forum User. Reason: added EA version
    eadocX Support

    Could I have some more details please:
    Operating system, citrix/not citrix, languages
    Where does the error occur?
    Have you run the installation verification test ? Extensions | eaDocX | Help | Check installation ?

    Forum User

    I’ve just run installation verification test and got an error (see screenshot in attachment)

    [code]”System.InvalidCastException: Unable to cast COM object of type ‘Microsoft…Word.ApplicationClass’ to interface type ‘Microsoft..Word._Application’. This operation failed because the QueryInterface call on the COM component for the interface with ID {ХХХ-ХХ…ХХ} failed due to following error: No such interface supported…”[/code]

    OS: Windows 7 32 bit
    language: English

    about “citrix” – what do you mean?

    • This reply was modified 11 years, 2 months ago by Forum User.
    eadocX Support

    This problem seems to be connected with having versions of some the Word DLLs on your machine from different versions of Word.
    Sometime this is because a machine used to have Office 2007/2010 components pre-installed, then office 2003 installed afterwards: the OS then has a mixture of 2003 and 2007 DLLs, which eaDocX can’t cope with. (or any other application which tries to inter-operate with word).
    Solution MAY be to de-install any Office 2007 PIA (Primary Interop Assembly) files from your machine.
    Can you say whether this is the case on your machine?

    (For future posters, the Word error was 0x8002801D TYPE_E_LIBNOTREGISTERED)

    Forum User


    I deinstalled Office 2007 PIA (Primary Interop Assembly) files from my machine.

    But the error remains.

    I have MS Office Live Meeting 2007 installed. May be it is the cause?

    eadocX Support

    Not sure that LiveMeeeting is the problem.
    I know its a real pain, but have you tried to install eaDocX on a different machine?
    Or, de-install Office, and re-install it ?

    Forum User

    I’m going to istall MS Office 2013 instead of 2010.
    Is EADocX compatible with 2013?

    eadocX Support

    As of the current release -3.3 – eaDocX works well with Word 2013.
    With Excel 2013, we have a work-around to get over a problem which Microsoft have introduced with 2013. They changed some of the internals, which means we can’t embed excel inside EA. instead, excel will run in an external window. Same function, but not quite so nice to use. We are trying to get Microsoft to fix this problem, or at least document a work around, but they seem surprised by the issue!

    Forum User

    I installed Office 2013 – and EADocX Check Installation works without errors!
    So the problem seems to be solved.


    eadocX Support

    Excellent! We only have a few customers who are using Office 2013 (as of March 2013) so your experiences are really valuable. Please update this thread with any more thought about 2013.

    Forum User

    unfortunately my trial licence expired yesterday…

    can I get prolongation of trial?
    taking in account the fact what I wasn’t able to use EADocX in this period due to the problem mentioned in this topic…

    anyway, thanks.

    eadocX Support

    No problem – given the difficulties you have had!
    I will send another 30-day trial licence to your email address

    Guillaume Finance

    I installed Office 2013 and Excel runs within an external window (no embedded window).
    I ran the Office update without any change.

    Installed version : Excel 2013 (15.0.4535.1507) MSO (15.0.4551.1007) 64 bits
    I’ve got Office pro plus 2013


Viewing 15 posts - 1 through 15 (of 18 total)
  • You must be logged in to reply to this topic.

Compare licence prices

Choose the licence that’s right for you and your team


Download a free trial

Download eaTeamWorks today for several free for life features, plus no obligation, 30-day trials of all the products: eaDocX, ea Revision Manager, eaSheets, Model Expert and PortfolioManager. Discover for yourself why we sell the world’s best-selling Enterprise Architect extension.