Home Forums eaDocX queries Project Glossary- eaDocX does not generate content

Home Forums eaDocX queries Project Glossary- eaDocX does not generate content

Viewing 15 posts - 1 through 15 (of 17 total)
  • Author
  • #8698

    Message ‘No element of type: Project Glossary in this repository.’

    I am using EA v12.1.1230 Corporate Edition in combination with eaDocX v3.9.1.1 Corporate Edition.
    Project Glossary is filled with multiple terms/types.
    eaDocX document contains terms. Repository content contains terms.
    eaDocX document has a Glossary Section inserted via the Insert menu-Project Glossary
    Both Generate Full of Generate this section(draft only) do not lead to any content.

    Any hints 🙂 ?

    eadocX Support

    Do you have a Profile for ‘Term’ in your document? If not, create one.
    Also, how did you create the ‘Glossary’ section? Best way is to use the insert/glossary option, and that will do everything for you.
    Also, don’t rename the Section called ‘Glossary’ – the name is a special one which eaDocX looks for when it comes to creating the glossary – any other name, and it won’t work.


    Profile for Term is present (containing Term and Definition)
    Glossary section was created by menu option insert, project glossary
    I did not rename the section

    More hints 🙂 ?

    eadocX Support

    Please can you send the Word document to, and I’ll take a look. Also the contents of your EA glossary (Export Reference Data / Project / Project Glossary).

    Mike Flewell

    Did this issue ever get resolved? I’m having the same issue so if it has been resolved could you please post the resolution.




    We gave eaDocX a sample of our repository and mentioned our EA, eDocX version. At their site this did work correctly. At our site we checked this issue with our other repositories and the problem did not occur there. The problem is not structural reproducible with EA, eaDocx in combination with PostgreSQL. What and who caused it, it is not determined.
    Perhaps you can try this with the latest eaDocX version?

    Brgds René

    eadocX Support

    I’ve just re-run the test cases for this, as well as creating some new ones, and it all seems to work for me, which is annoying.
    What I did was:
    (all done on PostgreSQL running under Windows 10)

    1. Started the database and EA
    2. Connected EA to PG using ODBC. Using PGAdmin v1.22
    3. Don’t know which PG version I’m using – where to find this ?
    4. Found some Glossary entries in EA (EA v13)
    5. created a Quick Document from the test EA Package. This package just has some text in the description field, which uses some of the terms in the glossary
    6. Added a new ‘Glossary’ section to the new document
    7. re-generated – glossary looks ok
    8. Added new term to the glossary, and added the test o the description. Re-generated OK

    Probably not a SQL error, because we use the Sparx API to fetch terms from the database.

    Mike Flewell

    This doesn’t work. I am using both a SQL server database connected with ODBC and a non-SQL database using just the EA .ldb. Also tried multiple documents. Any other suggestions?

    eadocX Support

    Is there a Profile for ‘Term’ in your document ? If not, create one.
    Please can you tell me the exact configuration you are running, and the step you are doing, so I can try to reproduce the issue.

    Mike Flewell

    Yes there is a Profile for Term. The columns are in this order: Term, Term Type, Definition, and I even added in Name. As well I’ve tried multiple variations of the column order as well as deleted both Term Type and Name with just the Term and Definition as the columns but same issue.

    The configuration is pretty standard with Sparx EA Ultimate 13.5.1351.

    Repository is Local EAP file
    Database version 7.0

    eaDocX Professional Edition Full Version

    What else do you need?

    eadocX Support

    please can you download the latest eaDocX version, and re-check that the issue is still there.

    Mike Flewell

    I have downloaded and installed version and I still have the same issue. Any other thoughts or suggestions?

    eadocX Support

    How did you add the Glossary?

    Mike Flewell

    If you mean how did I add the Glossary to the document in eaDocX I selected Insert–>Project Glossary at the place in the document where I wanted it.

    If you are referring to how I added terms to the EA Glossary I mostly did it through the Notes by selecting the context menu for the word(s) that I wanted to add as a term and then Create–>Glossary Definition.

    eadocX Support

    So we’re using the same eaDocX version, adding the glossary in the same way, and both have a ‘Term’ profile. And both creating glossary entries in the same way.
    So what’s different?
    Is this a new .EAp file, or are there any restrictions on it due to EA security?

Viewing 15 posts - 1 through 15 (of 17 total)
  • You must be logged in to reply to this topic.

Compare licence prices

Choose the licence that’s right for you and your team


Download a free trial

Download eaTeamWorks today for several free for life features, plus no obligation, 30-day trials of all the products: eaDocX, ea Revision Manager, eaSheets, Model Expert and PortfolioManager. Discover for yourself why we sell the world’s best-selling Enterprise Architect extension.