Home Forums eaDocX queries Word Table Style – Cell Padding

Home Forums eaDocX queries Word Table Style – Cell Padding

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
  • #6654
    Jaroslav Mlejnek

    When using Word Table Style for styling tables using MS Word 2010 table styles, eaDocx generated tables ignore cell padding.

    I attached the picture, where first table is properly formatted “hand-written” table and second table is generated table. My question is, how to achieve cell padding? Internal eaDocx table padding settings is (I think) ignored and my predefined padding in table style is ignored also.

    Thank you for your answers,

    eadocX Support

    You’re right that, when you use a Word Table Style, we don’t try to use the eaDocX-defined cell padding – the effects are unpredictable!
    I can’t seem to find a ‘cell padding’ setting in the Word Table definition (in Word). I think this may be because ‘cell padding’ is an HTML idea (eaDocX inserts tables into Word as lumps of HTML).
    I got the effect which I think you are looking for by editing the Word Table style and adding indentation to the paragraph settings for the table. This way, you can have different indentation for headings, first column, alternate columns etc.
    Probably more flexibility than is useful (this is Word after all!) but hopefully you’ll be able to get the look you want.

    Jaroslav Mlejnek

    Thank you for your answer. I have localized version of MS Office, so maybe “cell padding” is not correct translation for this Word feature.

    You can find this setting in Word:
    Table style edit dialog > Format button > Table properties (first item in my localized Word version in Format button context menu) > On first Table pane Properties button > Default cell padding section in the Table properties dialog. I attached three screenshots of my Word application, how to achieve showing this dialog.

    I tried your way using Paragraph options, it works only in horizontal direction – ie. there is space between text and left and right cell border. But rows are still thin (spacing before and after paragraph is ignored).

    Now, I found very interesting thing. When I select the table and manually force to use my word style, nothing happend. In previous case (using my “cell padding” way instead of “paragraph way”), the table has been reformated correctly. However, leaving style of table as it is after generation and by selecting “Normal” text style, the table is formatted correctly including top and bottom cell spacing.

    Weird. I know. But your plugin is exactly what I need and this fine-tuning will be very helpful for me. Thank you for your time.

Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.

Compare licence prices

Choose the licence that’s right for you and your team


Download a free trial

Download eaTeamWorks today for several free for life features, plus no obligation, 30-day trials of all the products: eaDocX, ea Revision Manager, eaSheets, Model Expert and PortfolioManager. Discover for yourself why we sell the world’s best-selling Enterprise Architect extension.